Soundprobleme mit Windows 7 64bit als VirtualBox Gast

Wer in SUNs VirtualBox ein Windows 7 als Gast installiert, hat mit dem Sound zumindest in der 32bit Version keine Probleme. Die simulierte Hardware ist ein Intel 82801AA AC’97 Audio Controller. Anders sieht es jedoch bei einem 64bit Windows 7 aus. Das erkennt die bereitgestellte Audio Hardware nicht.

Nach einiger Suche im Netz bin ich hinter des Rätsels Lösung gekommen. VirtualBox spendiert den virtuellen 64bit Gästen keine Intel Hardware sondern setzt dort auf eine emulierte Realtek Soundkarte. Was auch nicht weiter tragisch wäre, würde Windows 7 64bit die Hardware erkennen und einen geeigneten Treiber dafür installieren. Das war zumindest bei mir nicht der Fall.

Ergo musste ich von der Realtek Website einen Treiber für die AC’97 Audio Codecs (Software) herunterladen. Das gepackte ZIP Archiv enthält neben einigen Setups auch die Treiber für die manuelle Installation. Dazu wird das ZIP Archiv ausgepackt und anschließend im Gerätemanager für die nicht erkannte Soundkarte die Treiberaktualisierung aufgerufen.

Zum Installieren der eben heruntergeladenen Treiber muss auf dem Computer nach diesen gesucht werden. Dazu ist im nächsten Schritt der Ordner Vista64 aus den entpackten Dateien auszuwählen. Dort wird Windows 7 fündig und kann den richtigen Treiber installieren.

Danach präsentiert sich unser Windows 7 Gast mit funktionsfähiger Soundkarte.

Die Installation der nötigen Treiber ist nicht weiter tragisch, weiß man erst einmal um welchen Controller es sich handelt. Ich finde es nur schade, dass SUN versäumt hat für ihre 64bit Gäste einen Controller zu emulieren, den Windows 7 von Haus aus kennt. So wie sie es für die 32bit Gäste getan haben.

Soundprobleme mit Windows 7 64bit als VirtualBox Gast
Markiert in:             

13 Gedanken zu „Soundprobleme mit Windows 7 64bit als VirtualBox Gast

  • 3. März, 2010 um 9:46
    Permalink

    Hallo, vielen, vielen Dank für die Bereitstellung dieser Infos. Habe mich stundenlang mit diesem Problem herumschlagen müssen bis ich auf diese Informationen gestoßen bin. Sehr, sehr hilfreich. Gruß luminous58

  • 9. März, 2010 um 14:54
    Permalink

    Hi,

    super Beschreibung. Hat mein Problem gelöst.

    Host: Debian Linux (2.6.33 amd64)
    VirtualBox 3.1.4-57640
    Guest: Win7 Enterprise (64bit)

    Vielen Dank!

  • 4. April, 2010 um 20:11
    Permalink

    Hallo anrichter

    Besten Dank, jetzt geht der Sound einigermaßen. Leider ist bei mir der Ton aber sehr schlecht.. der Ton klingt irgendwie abgehackt, oder so als wenn die Schallplatte nicht mehr sauber läuft. Bei Musik habe ich ausserdem den Eindruck, dass die Geschwindigkeit variert.. sehr komisch. Kennen Sie ev. dieses Problem? Mein Setup:
    Win7 64 Wirt, Win7 64 Gast, Core i5, SSD, 4GB RAM.

    • 8. April, 2010 um 11:42
      Permalink

      Nein. Das Problem kenne ich nicht. Allerdings habe ich nicht die genannte Konstellation aus Wirts- und Gastsystem. Vielleicht kann jemand anders weiterhelfen?

      • 23. September, 2010 um 20:57
        Permalink

        Gibt es hierzu evtl. schon eine Lösung? Habe leider dasselbe Problem, ebenfalls Win7 64 Wirt/Gast

      • 23. September, 2010 um 20:57
        Permalink

        Gibt es hierzu evtl. schon eine Lösung? Habe ebenfalls das Problem mit selbem Wirt/Gast Setup.

  • 31. Mai, 2010 um 20:43
    Permalink

    Mich interesiert eher wie man überhaput ein 64Bit als Gast hinbekommt. Ich versuche es schon eine weile aber bekomme einfach nich das VB mein CPU als 64-Bit erkennt obwohl ich Win7 64-Bit als Wirt habe. Bitte um Hilfe !

    • 6. Juni, 2010 um 13:45
      Permalink

      Neue VM erstellen und im darauffolgenden Assistenten bei der Wahl der Betriebssystemversion die 64Bit-Variante wählen.

    • 31. August, 2010 um 14:20
      Permalink

      du musst wenn du dein pc startest die bios öffnen dann dort die visualisierung von amd dingens aktiviren dann geht es;) ich habe es so hinbekommen;)

  • 9. August, 2010 um 9:58
    Permalink

    Hallo,

    super Anleitung! Problem gelöst.

  • 12. September, 2010 um 17:39
    Permalink

    Klasse, die Idee ist so gut, daß sie von mir sein könnte! (*schmunzel* ; natürlich nicht wirklich!)
    Danke, klappt nun!

    Zwar ist bei mir die Wiedergabe stellenweise leicht verzerrt (nur Host natürlich), aber für das gebrauchte Bim-Bam von Windows reicht’s allemale.

  • 21. November, 2010 um 15:29
    Permalink

    bei mir hilft die Beschreibung.
    Ein Problem bleibt bestehen für ein „Basisgerät“ ???!
    Hierzu finde ich keine Lösung.

  • Pingback:Keine Soundprobleme mehr mit Windows 7 64bit in VirtualBox 4.0 | Andreas Richter

Kommentare sind geschlossen.