Windows 8: Treiber für ältere ATI Grafikkarten installieren

Die Installation der Windows 8 Consumer Preview verlief auf meiner betagten Hardware weitestgehend problemlos. Einzig die Grafikkarte wurde nicht als ATI Radeon X1200 erkannt und wurde mit einem Microsoft Basic Display Adapter betrieben. Doch es gibt einen Weg, wie auch ältere ATI Grafikkarten auf Windows 8 mit passenden Treibern versehen werden können.

Der Microsoft Basic Display Adapter funktioniert zwar für Windows 8, nutzt aber weder die native Auflösung von 1680×1050 Bildpunkten noch die Hardwarebeschleunigung. Auf der AMD Seite findet sich zwar ein Catalyst Treiber für Windows 8 Consumer Preview, dieser bringt aber leider nur Unterstützung für neuere Grafikkarten.

Windows 8 ist kompatibel mit Windows 7 und damit auch mit Windows Vista. Damit sollten die Legacy Treiber für alte ATI Grafikkarten auch auf dem neuen Windows laufen. Doch ganz so einfach ist die Installation dann doch nicht.

Nach dem Herunterladen der Treiber können und müssen diese zwar installiert werden, jedoch ändert sich allein davon nichts an den Grafikeinstellungen. Diese müssen per Hand auf den Legacy Treiber „aktualisiert“ werden.

Dazu öffnet man die Einstellungen für die Bildschirmauflösung per Rechtsklick auf den Desktop und wählt die erweiterten Einstellungen.

Bildschirmauflösung

In den erweiterten Einstellungen wählt man die Eigenschaften der Grafikkarte.

Erweiterte Eigenschaften

Dort angekommen klickt man noch auf Treiber aktualisieren

Eigenschaften von Microsoft Basic Display Adapter

und sucht im sich darauf öffnenden Dialog auf dem Computer nach Treibersoftware.

Treibersoftware aktualisieren

Als Suchpfad wird C:\ATI ausgewählt. Dort hin packt der ATI Legacy Treiber bei der Installation alle Dateien. In diesem Verzeichnis wird Windows 8 fündig und installiert den passenden Treiber für meine ATI X1200 Grafikkarte.

Treibersoftware aktualisiert

Und ab da steht mir die native Auflösung von 1680×1050 Pixeln sowie die Grafikbeschleunigung zur Verfügung. So macht Windows 8 schon mehr Spaß. Grad beim Visual Studio 11 zählt jedes Pixel…

Windows 8: Treiber für ältere ATI Grafikkarten installieren
Markiert in:         

32 Gedanken zu „Windows 8: Treiber für ältere ATI Grafikkarten installieren

  • 12. Mai, 2012 um 22:11
    Permalink

    Hast da ja jetzt auch 42 Pixel mehr im neuen Studio….da kann ich dich verstehen das du die nicht verschwenden möchtest 😉

    Antworten
  • 7. Juni, 2012 um 18:38
    Permalink

    Diese Information ist sehr hilfreich, auch für Release Preview. Danke für den Tipp.

    Antworten
    • 28. Juni, 2012 um 20:45
      Permalink

      Genau. Nach der Neuinstallation vom RP die Schritte erneut ausgeführt und die Grafik rennt wieder.

      Antworten
  • 28. Juni, 2012 um 19:48
    Permalink

    Habe so viel verschiedene Treiber ausprobiert, nichts hat funktioniert.

    Dann dieser Tip. Super Danke

    Antworten
  • 29. Juli, 2012 um 1:34
    Permalink

    Bei deinem 2ten Foto wurde schon dein Chipsatz erkannt. Das ist bei mir nicht so. Da steht :

    Also hattest Du schon nen Vorteil. Was mache ich wenn zwar WIN8 es als 4800 erkennt aber nicht den Grafikchip. Und den Treiber zu suchen geht auch nicht. Finder einfach ihn nicht in dem Verzeichnis wo ich ihn abgespeichert habe. Mal abgesehen davon, daß ein C:\ATI nicht angelegt wurde….Sonst noch ne Idee. Danke

    Antworten
  • 22. September, 2012 um 20:16
    Permalink

    Hallo,

    danke für die Hinweise. Beim Build 9200 klappt das Vorgehen unter Windows 8 32Bit und dem Treiber 10-2_legacy_vista32-64_dd_ccc.exe leider nicht. Windows 8 behauptet auch nach dem Durchsuchen des Verzeichnisses, dass der Microsoft Basis Treiber der aktuellste sei.

    Freundlicher Gruss

    Tom

    Antworten
    • 7. Oktober, 2012 um 17:26
      Permalink

      Hey, habe das gleiche Problem das Win8 die Behauptung in den Raum stellt, dass es den aktuellsten Treiber verwendet. Hat jemand schon eine Lösung für das Problem?
      Gruß
      Daniel

      Antworten
      • 25. Oktober, 2012 um 1:37
        Permalink

        Jo. Hier bei HD3560 und 12-6-legacy_vista_win7_64_dd_ccc_whql das Gleiche

        Antworten
    • 13. April, 2013 um 13:59
      Permalink

      Moin, dieses Problem hatte ich am Anfang auch. Daraufhin habe ich alle Ordner, die die ATI Software im Laufe meiner Versuche angegeben hat gelöscht. Danach die ganze Suite (95MB) heruntergeladen und die Catalyst-Installationsroutine sofort abgebrochen.
      Und siehe da, es wurde die X1200 erkannt und installiert, so wie Andreas es beschrieben hat.

      Antworten
  • 2. Januar, 2013 um 18:19
    Permalink

    Vielen Dank – eine tolle Problemlösung. Habe Windows 8 auf alten Dell Inspiron installiert und die ATI Radeon Xpress 1150 war „verschwunden“ – nur der Microsoft Basic Display Adapter wurde noch angezeigt. Alles mögliche gegoogelt und ausprobiert…und mit dieser Anleitung in 20 Sekunden die Grafikkarte wieder zum Leben erweckt.
    Hätte schon nicht mehr gedacht, diese Nuss zu knacken…
    Gruß
    Harald

    Antworten
  • 5. Januar, 2013 um 17:08
    Permalink

    Lieber Herr Richter,

    endlich einmal eine echte Hilfe im Internet!

    Hoffentlich bieten Sie noch mehr professionelle Hilfe an!

    Herlichen Dank

    Antworten
  • 13. Januar, 2013 um 20:58
    Permalink

    Vielen Dank für den guten Tipp.
    Es hat sich zwar innerlich alles gesträubt den ollen Vistatreiber auf das frische Win8-System zu installieren. Aber es hat die Probleme mit diesem hartnäckigen Microsoft-Basistreiber gelöst.
    Super! Ich hatte schon fast die Hoffnung aufgegeben!

    Viele Grüße
    Alex

    Antworten
  • 16. Januar, 2013 um 13:32
    Permalink

    Lieber Herr Richter,
    Sie haben mir sehr geholfen,man liest im Internet viele sogenannte „Experten“ Tips,sie haben es geschaft,ab sofort mein
    persönlicher Experte zu sein. Danke dafür !!

    Antworten
  • 24. Januar, 2013 um 21:13
    Permalink

    Hallo,
    das klingt nach Hoffnung. Meine Saphir Radeon HD 3650 AGP wird von Win8 32 Bit nur als Microsoft Basic Display Adapter erkannt.
    Bisher habe ich noch keinen Weg gefunden, dass ein anderer Treiber angenommen wird oder der Chip der Karte korrekt erkannt wird.

    Antworten
  • 27. Januar, 2013 um 0:01
    Permalink

    Vielen, vielen Dank,
    nach Tagen verzweifelter Suche wollte ich zurück nacvh XP.
    Jetzt klappt es wunderbar

    Antworten
  • 2. Februar, 2013 um 17:55
    Permalink

    Bomabastischer Tipp! Wollte W8 schon wieder deinstallieren.
    Jetzt sieht alles aus wie ich es haben möchte.

    Vielen Dank für diesen wertvollen Tipp!

    Antworten
  • 6. Februar, 2013 um 16:34
    Permalink

    Von mir auch vielen Dank, ich bin direkt auf diese Hilfe gestossen, als ich nach einer Lösung für dieses Problem gesucht hab und habe mir bestimmt ne Menge Zeit fürs rumprobieren erspart.

    Antworten
  • 6. Februar, 2013 um 19:40
    Permalink

    Jungs und Mädels, tausend Dank. Einfach Klasse! Ich war schon am Verzweifeln! Danke!

    Antworten
  • 19. Februar, 2013 um 15:08
    Permalink

    Prima. Nach Upgrade auf Windows 8 nur noch Microsoft Basic Display Adapter erkannt mit der Folge, dass Auflösung nur noch mit 1600 x 1200 statt 1920 x 10200 einstellbar war. Acer – Hotline 99 ct/Min und keine Lösung!
    Mit dieser Anleitung Problem in 20 Sekunden gelöst.
    Herzlichen Dank.

    Antworten
  • 22. März, 2013 um 0:58
    Permalink

    Ich war schon verzweifelt, weil bei meinem MSI VR610 der Legacy-Treiber nicht installieren ließ. Die Pfadangabe, wie Du sie beschreibst, brachte dann den Erfolg. Vielen Dank für den Tipp!

    Antworten
  • Pingback: Treiber Problem !

  • 4. Juni, 2013 um 14:41
    Permalink

    aber bei mir ist der ganze bildschirm schwarz nur unten sehe ich nur die zeit

    Antworten
  • 8. August, 2013 um 13:28
    Permalink

    Vielen dank für die Anleitung, jetzt funktioniert wieder alles so wie es soll, das man auch immer wieder alle neuen Treiber brauch, um die Grafikkarte einstellen zu können hätte ich mir auch gleich denken können. Lg. Tammy

    Antworten
  • 27. August, 2013 um 12:56
    Permalink

    Der Legacy Treiber passt auch für meine ATI Radeon 2100 Grafikkarte. Bei Windows 7 wird die Grafikkarte automatisch erkannt. Bei Windows 8 erkennt er diese nicht automatisch.

    Habe 4 Stunden lang alle möglichen Treiber ausprobiert. Es ging NUR mit den „Legacy Treiber für alte ATI Grafikkarten“.

    Hier nochmal der Downloadlink dafür: http://support.amd.com/us/gpudownload/windows/Legacy/Pages/integrated_vista64.aspx?type=2.7&product=2.7.2.3.2&lang=German

    Vielen Dank für deine Lösung!!! 🙂

    Antworten
  • 29. September, 2013 um 20:21
    Permalink

    Hallo Zusammen,
    als xp user hatte ich Windows8 auf meinem Celsius h240 istalliert. Dann die Ernüchterung: Meine ATI Mobility FireGL V5200 wurde nicht erkannt und durch den Windows8 Standardteiber ersetzt. Im Ergebnis stand mir somit die Auflösung 1920 x 1200 nicht mehr zur Verfügung.

    Ich hatte damals (nach Einführung von Windows8) alles versucht um das Problem zu lösen- um schliesslich nach einigen Wochen völlig entnervt wieder XP zu installieren. Die Beiträge geben mir Hoffnung, jedoch möchte ich nicht nochmals den „Circle“ machen. Hat jemand mit dieser ATI Grafikkarte und Windows8 Erfahung?
    Gruss und Dank
    Rulle

    Antworten
  • 24. Oktober, 2013 um 1:23
    Permalink

    vielen vielen vielen vielen dank mein grafik rennt jetzt extrem schennell

    Antworten
  • 15. Mai, 2016 um 14:19
    Permalink

    Für alle Interessierten:
    Habe das Prozedere eben auf dem HP mit Windows 10 1511 nachgestellt und auch dort tut der Legacy Treiber seinen Dienst.

    VG,
    Andreas

    Antworten
  • 29. Juni, 2016 um 20:52
    Permalink

    allgemeines Internet bla bla, funktioniert nur bis akualisieren,danach wird Grafikkarte gar nicht mehr im Manager angezeigt.
    Beim nächsten Hochfahren ist wieder Microsoft Basic Display Adapter am Zug

    Antworten
    • 30. Juni, 2016 um 8:21
      Permalink

      Hi Georg,

      schade, dass die Anleitung bei dir nicht funktioniert. Bei mir und vielen anderen hat sie es.
      Wer weiß, welche Konstellation bei dir von den hier erfolgreichen abweicht.

      VG,
      Andreas

      Antworten
  • 19. April, 2017 um 6:15
    Permalink

    Hallo,
    ich habe ein Dell Inspiron 6400 mit einer ATI X1400 und stehe auch vor dem Problem dess fehlenden Treibers. Leider kann ich unter dem oben angegebenen Link keinen Legacy Treiber finden. Entweder wurde dieser von der Seite entfernt oder, was ich für wahrscheinlicher halte, ich finde ihn nicht. Gibt es einen Direktlink zu dem Download?

    Gruß: Andreas

    Antworten

Kommentar verfassen